Jump to content
Star Party de Espacio Profundo - 10, 11 y 12 de Agosto Leer más... ×
Astronomia - Espacio Profundo
  • Registrarme
AldoWil

Problemas con la alineación en Registax 6

Recommended Posts

AldoWil

Hola gente, tengo un problema con un video en particular. Filmé el cráter Petavius a proyección por ocular, con SPC900+Ocular 25 mm + Barlow 2X. La puesta en estación del telescopio no es una maravilla pero zafa, viento no había en absoluto, es decir, el video es bastante estable. El problema es que no puedo alinear los fotogramas con Registax. Tengo otros videos parecidos y ningún problema. Es más, hice unos con ocular de 10 mm y anduvieron perfecto (y eso que eran de peor calidad).

¿Alguna sugerencia?

Les dejo la imagen que obtuve (ya está procesada con wavelets para que se note más la desalineación). Todos los intentos modificando configuraciones salieron igualitos.

5776b77030250_Petavius_20150206_0535_10(

Compartir este post


Enlace al post
Compartir en otros sitios
seba123neo

parece tener mucha aberracion, ¿ lo filmaste en mono o a color ? ¿ me pasas el video por privado para probar yo ?

Compartir este post


Enlace al post
Compartir en otros sitios
arieltrepin

A mi me pasa seguido!! Me adhiero a la pregunta!

Compartir este post


Enlace al post
Compartir en otros sitios
AldoWil

Lo filmé a color pero lo procesé de las dos formas, color y b/n. Me mataste, ¿cómo hago para pasarte por privado semejante tamaño de video? :oops:

Compartir este post


Enlace al post
Compartir en otros sitios
jwackito

Yo también quiero probar si no te molesta... Dropbox o google drive?

Pregunta. Cuantos puntos de alineación usaste? probaste usar uno solo?

Compartir este post


Enlace al post
Compartir en otros sitios
Chuli

Alineando los canales mejora mucho.

5776b77032aad_Petavius_20150206_0535_102

Compartir este post


Enlace al post
Compartir en otros sitios
Chuli
No. No mucho. :mrgreen:

Jajaja! si mejora!!!!

si abrís las dos y pasás de una a otra se nota. Tampoco va a hacer magia...

Compartir este post


Enlace al post
Compartir en otros sitios
Leoyasu

Aldo justo ayer estábamos jugando con Registax 6 y unos vídeos de la luna, tuvimos problemas similares e incluso, se generaban artefactos. Se nos sugirió probar con el Registax 4 o bien con el autostakkert. Saludos!

Compartir este post


Enlace al post
Compartir en otros sitios
seba123neo

poniendola en blanco y negro se le van todas las aberraciones, despues lo otro ya no se puede hacer mucho, ya que es problema de apilado.

Compartir este post


Enlace al post
Compartir en otros sitios
AldoWil

Gracias a todos!

Fitaje Chuli que igual siguen apareciendo los cráteres superpuestos. Yo también hice el alineado de RGB y mejora un poco.

Si alguien se le anima les dejo el link dropbox del video. La verdad que no sé si lo van a poder bajar, nunca compartí un archivo en dropbox de esta manera.

https://www.dropbox.com/s/7ika5r7bijram7l/Petavius_20150206_0535_10.avi?dl=0

Compartir este post


Enlace al post
Compartir en otros sitios
Hal9000

Normalmente los problemas de alineacion de registax, es porque hay algun salto "muy brusco" en el video.

Es importante que definas bien el ROI (area de interes), y el tamaño del recuadro. Podes probar con varios tamaños y seleccionando distintas areas para el seguimiento de la imagen.

Tambien hay parametros manuales de cual es la cantidad maxima de pixeles que se puede mover y que es capaz de seguir. Hay que jugar con esos parametros.

Por otra parte, si vas siguiendo uno a uno los fotogramas, te deberias dar cuenta en cual se modifica la alineacion, para eliminar esos cuadros manualmente del apilado.

Si son muchos, seguramente vas a tener que realinear.

En algunos videos me ha sucedido que he tenido que cortar el video en 2, y procesarlos por separado, ya que no hay forma de que el alineado siga al objeto debido a un salto grande.

Espero te sirva, saludos.

Compartir este post


Enlace al post
Compartir en otros sitios
Chuli

Aparte del alineado de canales, creo que el problema es que la imagen es un flan arriba de un auto en camino sinuoso. Evidentemente el seeing del día era muy malo y muy probablemente la Luna estaba baja.

No creo que se le pueda sacar mucho más de lo que lograste.

Saludos

Compartir este post


Enlace al post
Compartir en otros sitios
jwackito

Coincido con Eduardo de que la captura no es la mejor, pero apilando ~300 frames de 2000 se obtiene algo bastante pasable, excepto por el cromatismo. Me pregunto que si se podrá solucionar utilizando solamente el canal rojo para obtener una captura en blanco y negro pero sin cromatismo. El tema es que al no ser raw, el canal rojo ya está interpolado y contiene información del canal azul que es incorrecta debido a que el canal azul (y el verde) están desplazados más de un pixel... Voy a probar codear algo después para extraer el canal rojo del video (registax no lo tiene) y apilar solo eso a ver que sale. No tengo mucha fe pero con probar no se pierde nada.

Sugerencia para la próxima, utilizá un filtro rojo (aunque sea uno para visual) para hacer el video. El canal rojo se degrada menos que los de mayor longitud de onda y la aberración cromática debería desaparecer (en su mayor parte).

Si sale algo, lo subo.

Compartir este post


Enlace al post
Compartir en otros sitios
jwackito

Bue. Acá lo que probé. La salida del video la transformé en 2000 frames separados con mplayer. Sobre eso corrí un script (es una vergüenza llamarlo script, son menos de 10 lineas de python que ni guardé en un archivo, lo hice desde la consola, pero al que le interesa se lo mando) que devuelve otros 6000 frames, uno por cada canal de los 2000 originales. Dejo un ejemplo de un frame (el primer frame) de cada uno de los canales. Si, es el mismo primer frame. En el canal azul son todos como ese :/

Para que vean la diferencia entre procesar solo el rojo, el verde o el azul, les adjunto un ejemplo. Cada uno de los 2000 frames de cada canal los alineé en registax utilizando solo un punto (en el centro del cráter) y corté la calidad de los frames en 85%. En el canal azul detectó 278 frames, en el verde 435 y en el rojo 455. A cada apilada solo le apliqué ~50% de wavelets en la capa 1 y nada más.

Por ultimo les dejo una imagen procesada de solamente el canal rojo, con los seteos que más me gustaron... Ahora sí, no creo que se le pueda pedir más al video, pero valía la pena intentar :)

Gracias Aldo por compartir el video original...

petavius-final-red-135f.jpg.55861bbf05fe

petavius-red-455f.jpg.a7c6bb7edece532047

petavius-green-435f.jpg.eccbf1a487b83017

petavius-blue-278f.jpg.0cc728f9845157646

frame0_red.png.0e9e5eee4cdcc3d6b785aa8e1

frame0_green.png.845cf04470a0d0f04033ecb

frame0_blue.png.ef6c9f0e0038726fccc61ce2

00000001.png.2f076ff3d18da5fd9905377b0d0

Compartir este post


Enlace al post
Compartir en otros sitios
seba123neo

me baje el .avi

aca esta mi procesado, lo hice todo por defecto con el registax 6.

Compartir este post


Enlace al post
Compartir en otros sitios
AldoWil

Gracias a todos!

Te pasaste Juaquito con tu capacidad de procesamiento! Me dejaste al límite de mi conocimiento. No te digo que no entendí nada pero estoy ahí :o . Mejoró mucho y parece que el alineado se cumplió.

Compartir este post


Enlace al post
Compartir en otros sitios
jwackito

Jajajaja... como que no se entendió?

El finde armo un post aparte y explico bien como hice entonces. La joda es que se entienda.

Abrazo.

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión

×